手机浏览 RSS 2.0 订阅 膘叔的简单人生 , 腾讯云RDS购买 | 超便宜Qcloud , 注册 | 登陆

apache 2.2升到2.4的小坑

首页 > Linux >

 2.2升到2.4的小坑应该就出在权限上了

具体查看:https://httpd.apache.org/docs/current/upgrading.html
即,凡是遇到Order allow,deny allow from all等与Order相关的,最好看一下上面的链接。
比如我们用rewrite的时候,都是
XML/HTML代码
  1. Options Indexes FollowSymLinks 
  2. AllowOverride All  
  3. Order allow,deny  
  4. allow from all  

在2.4下面,上面的代码不报错,但不起作用。如果你的目录下面有.htaccess文件,那么,网站是打不开的,上面的代码改成

XML/HTML代码
  1. <Directory /var/www/>  
  2.     Options Indexes FollowSymLinks  
  3.     AllowOverride All  
  4.     Require all granted  
  5. </Directory>  
OK,再次打开就正常了

 




本站采用创作共享版权协议, 要求署名、非商业和保持一致. 本站欢迎任何非商业应用的转载, 但须注明出自"膘叔", 保留原始链接, 此外还必须标注原文标题和链接.

« 上一篇 | 下一篇 »

发表评论

评论内容 (必填):