手机浏览 RSS 2.0 订阅 膘叔的简单人生 , 腾讯云RDS购买 | 超便宜Qcloud , 注册 | 登陆

PhpStorm中因为JS版本低而提示错误的解决

首页 > Software >

开发项目的时候,发现:

大小: 33.33 K
尺寸: 500 x 179
浏览: 114 次
点击打开新窗口浏览全图

这是提示我,当前Javascript版本不支持

打开phpstorm的设置,进行语言和框架设置,选中Javascript,将版本设置为ECMAScript6。

大小: 47.99 K
尺寸: 500 x 113
浏览: 126 次
点击打开新窗口浏览全图
保存一下,再看刚才的文件,提示已经没有了
大小: 49.97 K
尺寸: 500 x 194
浏览: 95 次
点击打开新窗口浏览全图
 
由于以前只是用JS写写常用的东西,也没有注意过。果然使用ECMAScript6。虽然 VSCode什么的也可以,但切换来切换去的,总觉得不方便,而且这个设置只对当前项目有用,就先这么处理吧



本站采用创作共享版权协议, 要求署名、非商业和保持一致. 本站欢迎任何非商业应用的转载, 但须注明出自"膘叔", 保留原始链接, 此外还必须标注原文标题和链接.

Tags: phpstorm

« 上一篇 | 下一篇 »

只显示10条记录相关文章

我为什么会选用phpstorm (浏览: 39446, 评论: 5)
phpstorm试用 (浏览: 17405, 评论: 2)
phpstorm 函数提示 (浏览: 14689, 评论: 1)
备份:PhpStorm字体修改终极方案 (浏览: 13740, 评论: 0)
解决phpstorm 3.0 乱码问题 (浏览: 13727, 评论: 0)
官方wiki:Configuring PhpStorm IDE for Yii (浏览: 12787, 评论: 0)
收到phpstorm序列号 (浏览: 10549, 评论: 0)
phpstorm4:自定义代码折叠区域 (浏览: 10146, 评论: 1)
markdown编辑器 (浏览: 9154, 评论: 0)
Sublime Text 2 简介 (浏览: 9108, 评论: 0)

发表评论

评论内容 (必填):